tomcat报错请求的代码超过了65535字节限制。

 时间:2026-05-08 12:27:14

1、操作程序,从tomcat的日志文件里查到报错信息如下:

org.apache.jasper.JasperException: Unable to compile class for JSP:

An error occurred at line: 158 in the generated java file

The code of method _jspService(HttpServletRequest, HttpServletResponse) is exceeding the 65535 bytes limit.

2、这是因为tocmat请求的url地址过长导致的,修改tomcat的web.xml文件后,程序恢复正常

3、在:

<init-param>

<param-name>enablePooling</param-name>

<param-value>false</param-value>

</init-param>

下添加

<init-param>

<param-name>mappedfile</param-name>

<param-value>false</param-value>

</init-param>

重启tomat即可恢复正常

  • OSPF中的NBMA网络简介
  • chrome memory 使用方法
  • 隐藏/恢复快速切换用户功能的方法(Win10)
  • H3C交换机配置策略路由
  • Notepad++怎么高亮显示标签属性
  • 热门搜索
    厦门大学嘉庚学院怎么样 机械表走的快怎么办 会计怎么样 音乐符号图案大全 电视剧大全 鸡爪子怎么做好吃 癫痫的治疗方法 湖南农业大学怎么样 防盗门锁芯怎么换 血精的最佳治疗方法